Ylikerroin.com
Suomen suurin vedonlyöntisivusto
Tänään on 11.12.2017, 12:12

Kaikki ajat ovat UTC + 2 tuntia



Aloita uusi ketju Vastaa viestiin  [ 22 viestiä ] 
Kirjoittaja Viesti
 Viestin otsikko: Excel kysymys
ViestiLähetetty: 29.06.2007, 09:46 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
Jos minulla on excel-taulukossa jalkapalloliigan kauden tulosluettelo muodossa: kotijoukkue(A-F) - vierasjoukkue(A-F) - kotimaalit(X) - vierasmaalit(Y), niin kuinka saan tehtyä 1x2-jakaumat A-A, A-B jne. ottelupareille?
0


Viimeksi muokannut Rooney päivämäärä 11.07.2007, 02:16, muokattu yhteensä 2 kertaa
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 29.06.2007, 12:25 
Avatar
Status: JäsenLiittynyt: 14.01.2003, 12:22Viestit: 1313
Pisteitä: 198
Ehkä kannattaisi laskea mieluummin näin:

Otteluparin A vs A kotimaalit=
{=keskiarvo(jos(kotijoukkue_sarake="A";jos(vierasjoukkue_sarake="A";kotimaalit_sarake;"");""))}

Kaava pitää kuitata ctrl+shift+enter, jolloin siitä tulee vektorilaskutoimitus, eli nuo aaltosulkeet ympärille. Ja nuo lähdealueet pitää olla yhtä suuret.

En sitten kokeillut toimiiko tuo.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 29.06.2007, 12:37 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
Kirjoitin kaavan tähän tapaan soluun, mutta se ei toiminut.

={=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))}

Jossa,
B=kotijoukkue
C=vierasjoukkue
F=kotimaalit
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 29.06.2007, 12:52 
Status: JäsenLiittynyt: 22.08.2003, 14:27Viestit: 432Paikkakunta: Espoo :-(
Pisteitä: 0
Rooney kirjoitti:
Kirjoitin kaavan tähän tapaan soluun, mutta se ei toiminut.

={=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))}



=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))

Kaavan pitää olla näin kirjoitettuna, ja sitten siinä komentorivillä ollessasi painat ctrl+shift+enter ja sitten siihen ilmestyy kaavan ympärille { } merkit:

{=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))}
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 29.06.2007, 13:01 
Avatar
Status: JäsenLiittynyt: 14.01.2003, 12:22Viestit: 1313
Pisteitä: 198
Jos ei toimi, niin se johtuu tuosta keskiarvofunktiosta. Eli pitää laskea ensin summa ja jakaa sitten määrällä. Nyt huomasin samalla myös, että halusit pelkät 1X2 jakaumat etkä maalikeskiarvoja 8--)

kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 00:51 
Status: JäsenLiittynyt: 29.01.2004, 10:41Viestit: 296Paikkakunta: Tre
Pisteitä: 0
Oliver kirjoitti:
kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.


En oikein tiedä mitä teen väärin, mutta mä saan vaan aina vastaukseksi 0 tuosta ensimmäisestä kaavasta.
0

_________________
When life hands you lemons, ask for a bottle of tequila and salt.
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 08:48 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
Oliver kirjoitti:
kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.

Tämä kaava oli juurikin sellainen, jota hain. Kiitos avusta :D
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 10:33 
Avatar
Status: JäsenLiittynyt: 14.01.2003, 12:22Viestit: 1313
Pisteitä: 198
Tomzie kirjoitti:
Oliver kirjoitti:
kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.


En oikein tiedä mitä teen väärin, mutta mä saan vaan aina vastaukseksi 0 tuosta ensimmäisestä kaavasta.


Sarakkeita ei saa merkitä tyyliin B:B vaan B1:B65536 ja lähdealueet pitää olla yhtä suuret. Siinä jotain mitkä saattaa kusta....
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 11:41 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
Tomzie kirjoitti:
Oliver kirjoitti:
kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.


En oikein tiedä mitä teen väärin, mutta mä saan vaan aina vastaukseksi 0 tuosta ensimmäisestä kaavasta.

Malli:
1x2

412AA21
412AA31
412AA22
412AA41
AA12
AA10
AA02


Kaavat (3.rivi, sarakkeet 1-3):
=SUMMA(JOS(E3:E9="A";JOS(F3:F9="A";JOS(G3:G9>H3:H9;1;0);"");""))
=SUMMA(JOS(E3:E9="A";JOS(F3:F9="A";JOS(G3:G9=H3:H9;1;0);"");""))
=SUMMA(JOS(E3:E9="A";JOS(F3:F9="A";JOS(G3:G9<H3:H9;1;0);"");""))
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 12:07 
Status: JäsenLiittynyt: 29.01.2004, 10:41Viestit: 296Paikkakunta: Tre
Pisteitä: 0
Oliver kirjoitti:
Sarakkeita ei saa merkitä tyyliin B:B vaan B1:B65536 ja lähdealueet pitää olla yhtä suuret. Siinä jotain mitkä saattaa kusta....


Kaava on mullakin ihan oikein, sillä kokeilin sitä irrallisena pienessä erillisessä testiotoksessa (vrt. Rooneyn edellinen viesti). Se ei jotenkin hyväksy sitä mun analysoitavaa dataa. Jos on testitulokset ja oikea data (samalla tavalla jaettu soluihin kuin toinenkin) vierekkäin ja muutan vain kaavasta lähdealueet, niin sekään ei toimi. Olen "Format Cellsistä" yrittänyt vikaa löytää, mutta ei auta. Ennen kuin myönnän kädettömyyteni, niin syytän Exceliä, joka on Paholaisen tuotosta.
0

_________________
When life hands you lemons, ask for a bottle of tequila and salt.
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 12:38 
Avatar
Status: JäsenLiittynyt: 14.01.2003, 12:22Viestit: 1313
Pisteitä: 198
Tomzie kirjoitti:
Oliver kirjoitti:
Sarakkeita ei saa merkitä tyyliin B:B vaan B1:B65536 ja lähdealueet pitää olla yhtä suuret. Siinä jotain mitkä saattaa kusta....


Kaava on mullakin ihan oikein, sillä kokeilin sitä irrallisena pienessä erillisessä testiotoksessa (vrt. Rooneyn edellinen viesti). Se ei jotenkin hyväksy sitä mun analysoitavaa dataa. Jos on testitulokset ja oikea data (samalla tavalla jaettu soluihin kuin toinenkin) vierekkäin ja muutan vain kaavasta lähdealueet, niin sekään ei toimi. Olen "Format Cellsistä" yrittänyt vikaa löytää, mutta ei auta. Ennen kuin myönnän kädettömyyteni, niin syytän Exceliä, joka on Paholaisen tuotosta.


Kokeileppa, että maalaat ne ongelmasarakkeet, paina ctrl+h ja laita etsittäväksi "" ja jätä korvattava kohta -tyhjäksi. Data on todnäk tekstinä eikä siihen aina pysty vaikuttamaan muotoilupuolelta.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 12:56 
Status: JäsenLiittynyt: 29.01.2004, 10:41Viestit: 296Paikkakunta: Tre
Pisteitä: 0
Oliver kirjoitti:
Kokeileppa, että maalaat ne ongelmasarakkeet, paina ctrl+h ja laita etsittäväksi "" ja jätä korvattava kohta -tyhjäksi. Data on todnäk tekstinä eikä siihen aina pysty vaikuttamaan muotoilupuolelta.


siis pelkät hipsut? ei löytänyt mitään.
0

_________________
When life hands you lemons, ask for a bottle of tequila and salt.
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 13:27 
Avatar
Status: JäsenLiittynyt: 14.01.2003, 12:22Viestit: 1313
Pisteitä: 198
Tomzie kirjoitti:
Oliver kirjoitti:
Kokeileppa, että maalaat ne ongelmasarakkeet, paina ctrl+h ja laita etsittäväksi "" ja jätä korvattava kohta -tyhjäksi. Data on todnäk tekstinä eikä siihen aina pysty vaikuttamaan muotoilupuolelta.


siis pelkät hipsut? ei löytänyt mitään.


No kokeiles korvaa kohtaan "" ja korvattavaan "xxx" ja sitten korvaa kohtaan "xxx" ja korvattavaan ""

:lol:

Tai sitten data-alueella on oikeasti ylimääräsiä merkkejä, esim. jos on copypastetettu tulokset jostain niin helposti jää välilyöntejä numeroiden perään.

Välillä Excelin toiminta on mysteeri itsellenikin, vaikka sen kanssa on tullut tapeltua jo suht paljon.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 13:33 
Status: JäsenLiittynyt: 29.01.2004, 10:41Viestit: 296Paikkakunta: Tre
Pisteitä: 0
Oliver kirjoitti:
Tai sitten data-alueella on oikeasti ylimääräsiä merkkejä, esim. jos on copypastetettu tulokset jostain niin helposti jää välilyöntejä numeroiden perään.

Välillä Excelin toiminta on mysteeri itsellenikin, vaikka sen kanssa on tullut tapeltua jo suht paljon.


Joo, näyttäisi olevan välilyöntejä. Ei kuitenkaan numeroiden, vaan joukkueiden perässä. Saako niitä mitenkään poistettua muuten kuin manuaalisesti (niitä on erinäinen määrä)? Jos ei, niin voi olla, että loppuu tilastojen teko sillä kellonlyömällä (niitä on meinaan jokunen). :roll:
0

_________________
When life hands you lemons, ask for a bottle of tequila and salt.
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 30.06.2007, 14:12 
Avatar
Status: JäsenLiittynyt: 14.01.2003, 12:22Viestit: 1313
Pisteitä: 198
Tomzie kirjoitti:
Oliver kirjoitti:
Tai sitten data-alueella on oikeasti ylimääräsiä merkkejä, esim. jos on copypastetettu tulokset jostain niin helposti jää välilyöntejä numeroiden perään.

Välillä Excelin toiminta on mysteeri itsellenikin, vaikka sen kanssa on tullut tapeltua jo suht paljon.


Joo, näyttäisi olevan välilyöntejä. Ei kuitenkaan numeroiden, vaan joukkueiden perässä. Saako niitä mitenkään poistettua muuten kuin manuaalisesti (niitä on erinäinen määrä)? Jos ei, niin voi olla, että loppuu tilastojen teko sillä kellonlyömällä (niitä on meinaan jokunen). :roll:


Esim. funktiolla poista.välit.

Nää on ihan perusjuttuja, jotka löytyy helppidokkarista nopeammin kuin kysymällä. Isompia systeemejä haikailevien kantsii lukaista esim. Excel Bible tai vielä parempi Excel Power Programming with VBA. Excelillä kun voi tehdä sellaisia juttuja, että moni omia softiaan rakenteleva jannu ei tajuakaan :)
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 02.07.2007, 03:52 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
Lisäkysymys vielä samaan topicciin...

Kuinka saan kopioitua solun, jossa on kaava siten, että kopioitavaan soluun ei tule kaavaa, vaan kaavan tulos?
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 02.07.2007, 07:57 
Status: JäsenLiittynyt: 30.09.2005, 19:40Viestit: 19
Pisteitä: 2
Rooney kirjoitti:
Lisäkysymys vielä samaan topicciin...

Kuinka saan kopioitua solun, jossa on kaava siten, että kopioitavaan soluun ei tule kaavaa, vaan kaavan tulos?


Normaalin Paste-komennon sijaan Paste Special (oliskohan ollut suomenkielisessä "Liitä Määräten") ja sieltä valinta Values.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 16.08.2007, 11:35 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
Osaako joku neuvoa seuraavassa excel-pulmassa?

Kuinka saan luotua soluun soluviittauksen niin, että se säilyy sitä kopioitaessa? ("kiinteän" soluviittauksen)

Kun normaalisti kopioitaessahan tapahtuu niin, että jos kopioin esimerkiksi solua, jossa on viittaus viereiseen soluun, solun alapuolelle, myös viittaus siirtyy yhden solun alemmaksi. (B22)=C22 ----> (B23)=C23

HUOM. Muiden solussa olevien viittauksien pitääkin säilyä sellaisina, että muuttuvat kopioitaessa.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 16.08.2007, 11:45 
Status: JäsenLiittynyt: 11.02.2007, 11:35Viestit: 126
Pisteitä: 0
Jos haluat että vaikka B22 pysyy samana. Laitat dollarit $B$22. Helpoiten onnistuu kun laitat kursorin B:n ja 22:n väliin ja painat F4:ää.

Ilmeisesti tätä hait. Tai sitten ymmärsin väärin :D
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 16.08.2007, 15:14 
Status: JäsenLiittynyt: 12.04.2007, 16:30Viestit: 675
Pisteitä: 0
squeeze kirjoitti:
Jos haluat että vaikka B22 pysyy samana. Laitat dollarit $B$22. Helpoiten onnistuu kun laitat kursorin B:n ja 22:n väliin ja painat F4:ää.

Ilmeisesti tätä hait. Tai sitten ymmärsin väärin :D

Juuri tuota hain :D
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 19.01.2009, 22:15 
Status: JäsenLiittynyt: 14.07.2004, 22:20Viestit: 222
Pisteitä: 3
Lainaanpa vanhaa ketjua, niin tarvi turhaan tehdä uutta.

Saako Excelissä jotenkin muokattua tätä alareunan välilehdet-osiota esim. kaksikerroksiseksi ? Harmittaa vietävästi aina skrollata näillä kankeilla namiskoilla tätä palkkia edestakaisin, kun kuitenkin välilehtiä on kertynyt kohtuu mukava määrä ajan saatossa. Esim Windowsin työpöydässähän kyseisen "venyttämisen" voi tehdä ihan vain tarraamalla yläreunasta hiirulaisella kiinni ja vetämällä haluamansa korkuiseksi.
0
Ylös
  Profiili
 
 Viestin otsikko:
ViestiLähetetty: 20.01.2009, 09:58 
Status: JäsenLiittynyt: 22.08.2003, 14:27Viestit: 432Paikkakunta: Espoo :-(
Pisteitä: 0
Mikäänhän ei estä sinua pienentämästä niiden välilehtien nimiä vaikkapa kahden kirjaimen pituisiksi ja voit pienentää sitä oikeassa alakulmassa olevaa vierityspalkkia aika paljon. En tiedä kuinka paljon välilehtiä kaipaat auki, mutta läppärissäni 15.4" näytölle mahtuu noin 20 välilehteä joiden nimen pituus on seitsemisen merkkiä/välilehti. 20" näytölle näyttää mahtuvan Sheet1-Sheet27 nimiset välilehdet, joten kyllä niitä ilman kahteen tasoon saamistakin aika monta saa mahtumaan.
0
Ylös
  Profiili
 
Näytä viestit ajalta:  Järjestä  
Aloita uusi ketju Vastaa viestiin  [ 22 viestiä ] 

Kaikki ajat ovat UTC + 2 tuntia


Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 2 vierailijaa


Et voi kirjoittaa uusia viestejä
Et voi vastata viestiketjuihin
Et voi muokata omia viestejäsi
Et voi poistaa omia viestejäsi
Et voi lähettää liitetiedostoja.

Hyppää:  


Powered by phpBB © 2008 phpBB Group | Käännös, Lurttinen, www.phpbbsuomi.com
subSilver+ theme by Canver Software, sponsor Sanal Modifiye